SAS JMP

From NCSSM Wiki
Jump to navigation Jump to search

Please use the following instructions to download and install SAS JMP 10.

Please note that a valid NCSSM Google account is required to authenticate, download, and license this software.

Instructions for Windows

  1. Navigate to Software Downloads on My NCSSM and select SAS JMP - Mac & Win. Alternately, you can click this direct link.
  2. Download the JMP 10_Win_x64 & Mac.zip file. This file contains the SAS JMP installers for both Windows and Macs machines. Please note that this download can take a long time to complete.
  3. Download the .txt file for Win.
  4. By default, this .zip file will be downloaded to your Downloads folder. This is a compressed or zipped file and the contents must be extracted. Do not extract in the Downloads folder, however.
  5. Create a "temp" folder on your C:\ drive and then a "JMP" folder inside the temp folder.
  6. Right click on the downloaded JMP zip file in Downloads and select Extract All. Browse to C:\temp\JMP and unzip the files.
  7. Open the JMP 10 folder in the temp folder and find "setup.exe" (this installer will be located here: JMP/JMP/10_0/Windows/JMP/setup.exe). Right click on Setup and select Run as administrator to install the software.
  8. You are then required to renew the license for SAS JMP 10. Use the .txt license file you downloaded in step 3.
  9. Launch SAS JMP by double-clicking your JMP desktop icon or using the Start menu.
  10. Licensing Option 1: If your JMP license is past your expiration date, the first screen you see at JMP launch is a message that your JMP license is expired.
    1. Click Open License.
    2. At the prompt, navigate to where you saved the license file; this should be in the Downloads folder.
    3. Click Open.
    4. Enter an Administrator Name and Department if you desire.
    5. Click OK.
  11. Licensing Option 1: If your JMP license has not expired, you must start the renewal process manually.
    1. From the File menu, select New > Script to open a script window.
    2. Enter this line: renew license();
    3. From the Edit menu, select Run Script.
    4. In the resulting "Renew Your JMP License" window, click Open License.
    5. At the prompt, navigate to where you saved the license file.
    6. Click Open.
    7. Enter an Administrator Name and Department if you desire (not required)
    8. Click OK.
  12. After completing the SAS JMP software installation and license renewal, download and run the following update for JMP 10.02: Windows: Win_JMP_1002_AL_Updater.exe.

SAS JMP is now properly installed.

Instructions for Mac

  1. Navigate to Software Downloads on My NCSSM and select SAS JMP - Mac & Win. Alternately, you can click this direct link.
  2. Download the JMP 10_Win_x64 & Mac.zip file. This file contains the SAS JMP installers for both Windows and Macs machines. Please note that this download can take a long time to complete.
  3. Download the .txt file for OSX (Mac).
  4. By default, this .zip file will be downloaded to your Downloads folder. Double-click the zip file unzip the installation files.
  5. Open the resulting JMP 10 folder folder and find "JMP-10.dmg" (this installer will be located here: JMP/JMP/10_0/Macintosh/JMP-10.dmg). Double-click on JMP-10.dmg and then right-click on the JMP 10.pkg that appears and click Open. Click Open again when prompted.
  6. Complete the installation by following the directions in the installer.
  7. You are then required to renew the license for SAS JMP 10. Use the .txt license file you downloaded in step 3.
  8. Launch SAS JMP by double-clicking the SAS JMP application in your Applications folder.
  9. Licensing Option 1: If your JMP license is past your expiration date, the first screen you see at JMP launch is a message that your JMP license is expired.
    1. Click Open License.
    2. At the prompt, navigate to where you saved the license file; this should be in the Downloads folder.
    3. Click Open.
    4. Enter an Administrator Name and Department if you desire.
    5. Click OK.
    6. If prompted to save a .per file, save this file in the same location where you saved the license file.
  10. Licensing Option 1: If your JMP license has not expired, you must start the renewal process manually.
    1. From the File menu, select New > Script to open a script window.
    2. Enter this line: renew license();
    3. From the Edit menu, select Run Script.
    4. In the resulting "Renew Your JMP License" window, click Open License.
    5. At the prompt, navigate to where you saved the license file.
    6. Click Open.
    7. Enter an Administrator Name and Department if you desire (not required)
    8. Click OK.
    9. If prompted to save a .per file, save this file in the same location where you saved the license file.
  11. After completing the SAS JMP software installation and license renewal, download and run the following update for JMP 10.02: Mac: Mac_JMP-1002-AL-Updater.dmg.

SAS JMP is now properly installed.